GitHub API calls are succeeding but we continue to monitor the situation.
Posted Jun 10, 2026 - 19:09 UTC
Identified
We are seeing some deployments fail because of GitHub HTTP 504 responses. A subset of deployments seems to be affected across all regions.
Posted Jun 10, 2026 - 17:23 UTC
This incident affected: Build Service (Build Service - US East (Ohio), Build Service - US East (Virginia), Build Service - Canada (Central), Build Service - EU Central (Frankfurt), Build Service - EU West (Ireland), Build Service - EU West (London), Build Service - Asia Pacific (Singapore), Build Service - Asia Pacific (Sydney), Build Service - Asia Pacific (Tokyo)) and Deployments (Deployments - US East (Ohio), Deployments - US East (Virginia), Deployments - Canada (Central), Deployments - EU Central (Frankfurt), Deployments - EU West (Ireland), Deployments - EU West (London), Deployments - Asia Pacific (Singapore), Deployments - Asia Pacific (Sydney), Deployments - Asia Pacific (Tokyo)).