The configuration issue affecting FPM worker counts on larger compute sizes has been resolved. Monitoring confirms the fix is working as expected for new deployments.
We have identified all environments that were potentially impacted and are reaching out to those customers directly with details and next steps. If you have not been contacted, your environment was not affected.
If you were affected and want to apply the fix immediately, redeploying your application will pick up the corrected configuration. You can verify worker counts on your environment's Metrics page under the Web workers graph.
Thanks for your patience while we worked through this.
Posted May 18, 2026 - 19:33 UTC
Monitoring
We identified a configuration issue that caused some environments running on larger compute sizes to be provisioned with fewer FPM workers than expected. Only applications that deployed today (Monday May 18, 2026) were potentially affected.
A fix has been deployed and we are monitoring the results.
What to do if you may be affected:
If your app deployed today and you've noticed degraded performance or request queuing, you can confirm impact by visiting your environment's Metrics page and checking the Web Workers graph — if the worker limit dropped recently, your environment was affected. To apply the fix, simply redeploy your application. New deployments will pick up the corrected configuration automatically. We'll post another update once monitoring confirms the fix is fully effective. We apologize for the disruption.
Posted May 18, 2026 - 19:23 UTC
This incident affected: App compute (App compute - US East (Ohio), App compute - US East (Virginia), App compute - Canada (Central), App compute - EU Central (Frankfurt), App compute - EU West (Ireland), App compute - EU West (London), App compute - Asia Pacific (Singapore), App compute - Asia Pacific (Sydney), App compute - Asia Pacific (Tokyo)).