The upstream npm issue has been resolved and we are seeing deployment times returning to normal levels. We will keep monitoring for any regressions.
Posted Sep 04, 2026 - 14:02 UTC
Update
We are continuing to monitor the situation, and will update once the upstream issue is resolved.
Posted Sep 04, 2026 - 03:48 UTC
Identified
We've traced the slower deployments to npm. Package installs are timing out or taking much longer than usual, which extends the build step. If yours times out, please try again.
Posted Sep 04, 2026 - 00:21 UTC
Investigating
We are currently investigating longer than usual deployment times. Deployments are still completing, just slower than normal. If your deployment times out, please try to deploy again.
Posted Sep 03, 2026 - 22:58 UTC
This incident affected: Deployments (Deployments - US East (Ohio), Deployments - US East (Virginia), Deployments - Canada (Central), Deployments - EU Central (Frankfurt), Deployments - EU West (Ireland), Deployments - EU West (London), Deployments - Asia Pacific (Singapore), Deployments - Asia Pacific (Sydney), Deployments - Asia Pacific (Tokyo)).