Cloud dashboard slow to load

Incident Report for Laravel Cloud

Resolved

The Cloud dashboard is responding normally again.
Posted Sep 10, 2026 - 15:53 UTC

Monitoring

The Cloud dashboard is responding normally again. We're continuing to monitor.
Posted Sep 10, 2026 - 15:22 UTC

Identified

We've identified the cause and applied a mitigation. Response times in the Cloud dashboard are improving.
Posted Sep 10, 2026 - 15:14 UTC

Investigating

We're investigating slow response times and intermittent timeouts in the Laravel Cloud dashboard.
Your running applications are not affected and continue to serve traffic normally.
Posted Sep 10, 2026 - 14:50 UTC
This incident affected: Cloud Control Panel.