Degraded performance in Cloud dashboard

Incident Report for Laravel Cloud

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 14:23 UTC

Monitoring

The issue has been identified and resolved.
The team is now monitoring the Cloud control panel performance
Posted Apr 27, 2026 - 14:11 UTC

Investigating

We are currently investigating this issue.
Posted Apr 27, 2026 - 13:56 UTC
This incident affected: Cloud Control Panel.